Draftsight – Blöcke und Linien

Aktualisiert am 17.03.2019 (1150)
Beginnen und beenden Sie jede Aktion in DraftSight mit ESC – so brechen Sie den eventuell aktiven Befehlsmodus ab und erhalten keine unerwarteten Ergebnisse

Blöcke

Eigenschaften

links: Block mit verschiedenen Elementen
rechts: markierter Block mit Basispunkt

Mehrere Zeichenobjekte (Komponenten) wie Punkte, Linien, Text etc. können in einer Zeichnung als Block zusammengefasst werden. Einem Block wird ein Basispunkt zugewiesen, über den seine Position in der Zeichnung definiert wird.

Die Koordinaten des  Basispunkts können frei gewählt werden, standardmäßig sind es 0,0,0. Wird ein Block angeklickt (markiert), so wird der Basispunkt aktiviert. Über diesen kann der ganze Block z.B. verschoben werden. Die einzelnen Komponenten des Blocks sind nicht selektierbar.

Desweiteren hat ein Block diese Eigenschaften:

  • Die Komponenten eines Blocks können aus unterschiedlichen Ebenen stammen
  • Der Block selbst kann einer einzigen, beliebigen Ebene zugeordnet werden
  • Die Farben der Objekte und Linienstile bleiben erhalten und nehmen z.B. nicht die Eigenschaft der Ebene an, in die der Block eingefügt wird
  • Wird ein Block definiert, erhält er einen Namen und wird als Vorlage (Referenz) in der aktuellen Zeichnung gespeichert
  • Ein einmal definierter Block kann beliebig oft in die Zeichnung an beliebiger Stelle eingefügt werden. Der ursprüngliche Block – die Vorlage – wird also referenziert. In der DWG-Datei wird an der Stelle, an der ein Block mit seinem Basispunkt eingefügt wird, lediglich ein Verweis auf die Geometrie des Referenz-Blocks mit abgespeichert, d.h. beim Einfügen eines mit Namen bekannten Blocks wird quasi ein „Link“ auf den Referenz-Block in die Zeichnung eingefügt.
  • Werden alle Blöcke mit gleichem Namen aus der Zeichnung gelöscht, bleibt dennoch die Vorlage (Referenz) erhalten.
  • Die Blockvorlage selbst kann nur gelöscht werden, wenn zuvor in der Zeichnung alle Blöcke gleichen Namens gelöscht wurden.
  • Ein Block kann modifiziert werden. Diese Änderungen wirken sich auf alle Blöcke gleichen Namens in der Zeichnung aus.
  • Blöcke können als eigenständige DWG-Dateien gespeichert werden. Der Basispunkt erhält automatisch die Koordinaten 0,0,0. Somit können Bibliotheken von häufig genutzten Symbolen erstellt werden.

Verwendung von Blöcken

Symbole in Pänen

Symbole für besondere Objekte in einer Zeichnung, wie z.B. Bäume, Hydranten oder Muffen, werden maßstäblich 1:1 in der Modellansicht als Block erstellt. Sie bestehen üblicherweise aus mehreren Linien und haben ein zentralen Basispunkt, über den die Koordinaten des Symbols definiert sind. Dieser Basispunkt ist ein charakteristischer Eckpunkt oder Linienendpunkt des Symbols, z.B. der Mittelpunkt des Symbols oder der Mittelpunkt oder linke Eckpunkt der unteren Basislinie des Symbols.

Symbole sollten so groß gewählt werden, dass sie im Ausdruck der Blattansicht gut erkennbar sind. Beträgt der Maßstab im Ausdruck 1:500, so beträgt die sinnvolle Symbolgröße 0.5 bis 2 CAD-Einheiten (0.5…2m). Im Ausdruck ist das Symbol dann 1 bis 4 mm groß.

Für die Druckansichten (Blatt, Sheet) können ebenfalls Blöcke definiert werden, z.B. Plankopf, Impressum, Legende oder Nordpfeil. Hier ist darauf zu achten, dass die Blockzeichnungen in mm erstellt werden.

Erkundigen Sie sich bei Ihrem Auftraggeber, bei der Landesvermessung oder bei Kollegen, welche Symbole verwendet werden. Für bestimmte Objekte auf topografischen und Katasterkarten (topografische Punkte, Höhenmesspunkte, Denkmal, Grenzpunkte …) gibt es festgelegte und allgemein verwendete Symbole. Für z.B. Kabelnetzwerke können die Symbole betreiberabhängig sein.
Hinterlegung von Kartenmaterial

Soll unter den selbst gezeichneten Plan zwecks Orientierung eine Karte hinterlegt werden (z.B. ein Katasterplan), so kann wie folgt vorgegangen werden:

  • Der Katasterplan wird separat geöffnet
  • Ein passender Kartenausschnitt wird herausgeschnitten bzw. nicht benötigte Teile gelöscht
  • Alle Objekte/Ebenen werden einheitlich hellgrau eingefärbt
  • Der Kartenausschnitt wird daraufhin als Block definiert mit Basispunkt 0,0,0.
  • Über die Zwischenablage kann dieser Block dann in den eigenen Plan in einen separaten Layer eingefügt werden.
Üblicherweise ist es schlechter Stil, mehrere Ebenen per Block in eine einzige Ebene zusammenzufassen. Dies sollte nur gemacht werden, wenn der hinterlegte Plan nur zur Orientierung genutzt und nicht digital weiterverwendet werden soll.

Einen Block definieren

Ein Straßenablauf (Gully) soll als Block definiert werden in Form eines Rechtecks mit zentralem Diagonalkreuz und den Abmessungen 0.6 x 0.4 m.

Zuerst wird das Rechteck in den Layer 0 an beliebiger Stelle gezeichnet:

  • Menu>Zeichnen>Rechteck
  • in der Zeichnung die gewünschte Stelle für die Erstellung der Grafik anklicken (dies wird die linke untere Ecke des Rechtecks)
  • Tastatureingabe: bemaßung>RETURN
  • 0.6 RETURN
  • 0.4 RETURN

0.6 und 0.4 beziehen sich auf die Einheit „Meter“. Achten Sie darauf, dass in den Optionen „Meter“ gewählt sind (*):

Dann werden die zwei diagonale Linien in das Rechteck eingezeichnet. Gestalten Sie anschließend Farben und Linienstile, und definieren Sie das neue Symbol als Block:

Menu>Zeichnen>Block>Definieren

oder

Tastatureingabe: block>RETURN

  • Geben Sie einen Namen für den Block ein, hier: Gully
  • Einheitlichen Maßstab anwenden aktivieren (Breite und Höhe würden bei Größenänderung maßstäblich geändert)
  • Auflösen des Blocks erlauben aktivieren
  • Den Basispunkt im Grafikbereich angeben: Kreuzungspunkt der beiden Linien anklicken
  • Die Elemente im Grafikbereich angeben: Markieren des gesamten Symbols: linke Maustaste drücken und Rechteck um Symbol zeichnen, dann RETURN. Alternativ alle Elemente anklicken, dann RETURN.

Mit OK wird die Blockdefinition abgeschlossen.

Mit dem Abschluss dieser Blockdefinition wird eine Vorlage des Blocks (Referenz) in der aktuellen Zeichnung erstellt und kann beliebig oft in die Zeichnung eingesetzt (referenziert) werden. Soll der Block in einer anderen Zeichnung verwendet werden, muss es per copy&paste übertragen oder als einzelnes DWG in ein Bibliotheksverzeichnis exportiert und in die andere Zeichnung importiert werden.

(*)

Menu>Extras>Optionen>Systemoptionen>Voreinstellungen für Zeichnungsdatei

Menu>Extras>Optionen>Zeichnungseinstellungen>Einheitensystem

Einen Block einfügen

Aktivieren Sie zuerst den gewünschten Layer in der Layer-Auswahlliste.

Unter

Menu>Einfügen>Block
kann das Fenster „Block einfügen“ geöffnet werden. Alternativ:

Tastatureingabe: ALT n>b>RETURN oder blockeinfügen>RETURN

  • Wählen Sie den Block namens „Gully“ aus
  • Position später eingeben aktivieren => somit „klebt“ der Block mit seinem Basispunkt beim Einfügen am Mauszeiger und kann an beliebiger Stelle abgesetzt werden.
  • Maßstab später eingeben wird nicht aktiviert, er bleibt 1, ebenso ist eine Rotation des Blocks meistens nicht erforderlich
  • Die Blockeinheit muss Meter sein (unveränderlich)

Mit OK wird das Fenster geschlossen.

Auf der Zeichenfläche erscheint nun der Block mit seinem Basispunkt unter dem Mauszeiger und kann an der gewünschten Position abgesetzt werden. Der Farb- und Linienstil des Blocks kann nicht über die Blockeigenschaften geändert werden!

Erscheint der gewünschte Blockname nicht in der Auswahlliste, wurde der Block noch nicht in dieser Zeichnung definiert. Sie haben dann diese Möglichkeiten:

Neudefinition des Blocks in aktueller Zeichnung

Siehe oben.

Öffnen einer anderen Zeichnung, in der der Block definiert und in der Grafik verwendet wird:

Einfügen mit freier Wahl der Zielkoordinaten:

  • Block markieren > rechter Mausklick > Kopieren in Zwischenablage
  • Zeichnung wechseln > rechter Mausklick > Einfügen

Einfügen mit Zielkoordinaten = Quellkoordinaten:

  • Block markieren > rechter Mausklick > Mit Referenzpunkt kopieren
  • Tastatureingabe: 0,0,0 RETURN
  • Zeichnung wechseln > rechter Mausklick > Einfügen
  • Tastatureingabe: 0,0,0 RETURN
Laden des Blocks aus einer Bibliothek (Block liegt als externe DWG-Datei vor):

Klicken Sie im Fenster „Block einfügen“ auf Durchsuchen. Finden Sie nicht die gewünschte Blockdatei, ist entweder der Pfad zum Bibliotheksverzeichnis falsch gesetzt (siehe

Menu>Extras>Optionen>Dateipositionen
) oder es wurden noch keine Symbole exportiert und in diesem Verzeichnis abgelegt. Sobald der Block in die Zeichnung aufgenommen wurde, ist es in der Liste auswählbar.

Laden Sie alle Symbole, die zur Erstellung einer Zeichnung benötigt werden, in einen „Masterplan“, der für neue Zeichnungen als Vorlage dient. Löschen Sie alle Blöcke aus der Zeichnung, so dass lediglich die Blockdefinition in der Auswahlliste des „Block-Einfügen“-Fensters bestehen bleibt und speichern die Datei als Vorlage-Datei (DWT) ab.

Blöcke löschen

Werden in einer Zeichnung alle Blöcke eines Typs gelöscht, bleibt dennoch die Blockdefinition erhalten. Der Blockname erscheint weiterhin in der Auswahlliste im Fenster „Block einfügen“.

Die Blockdefinition wird komplett entfernt:

Menu>Datei>Bereinigen>Nicht referenzierte Elemente
: „Gully“ auswählen und löschen.

Erscheint „Gully“ nicht in dieser Liste, befindet sich noch ein Symbol „Gully“ irgendwo auf dem Plan. Bevor dieses nicht gelöscht ist, kann die Blockdefinition nicht gelöscht werden.

Blöcke auflösen (sprengen)

Folgende Aktionen funktionieren nur, wenn während der Block-Definition Auflösen erlauben aktiviert wurde.

Im Fenster „Block einfügen“ kann die Option“Block auflösen“ gewählt werden. Der Block wird in seine Elemente zerlegt in die Zeichnung eingefügt. Die einzelnen Elemente gelangen in ihre ursprünglichen Layer.

  • >Menu > Ändern > Auflösen
  • Block markieren
  • RETURN

oder

  • Block markieren
  • Tastatureingabe: auflösen

 

 

 

Eine Symbolbibliothek erstellen

Eine Symbolbibliothek ist ein Verzeichnis, in das eine Sammlung von Symbolen/Blöcken jeweils als kleine DWG-Datei abgelegt wird. Von dort können die Symbole einzeln in jede andere Zeichnung importiert werden.

Erstellen Sie ein zentrales Verzeichnis auf dem Rechner oder auf dem Server mit einem Unterverzeichnis „Symbole“. Befindet sich das Verzeichnis auf dem Server, kann von mehreren Arbeitsplätzen darauf zugegriffen werden. Passen Sie den Suchpfad an:

Menu>Extras>Optionen>Dateiposition>Zeichnungsunterstützung>Symbolverzeichnis

Erstellen Sie ein Symbol als Block, und exportieren Sie den Block über

Menu>Datei>Exportieren>Zeichnung
oder Tastatureingabe: wblock>RETURN

Der Block wird nach seinem Namen ausgewählt, dann wird das zentrale Symbolverzeichnisses (s.o.) gesucht und der Block als Gully.dwg abgespeichert. Der exportierte Block Gully.dwg kann wie jede andere DWG-Datei mit DraftSight geöffnet werden. Der Basispunkt hat die Koordinaten 0,0, Breite und Höhe betragen 0.6 bzw. 0.4 m. Achten Sie auf die Einheit „Meter“. Aus diesem Verzeichnis heraus können die Symbole in jede beliebige Datei eingefügt werden.

Statt einer Bibliothek in Einzeldateiform können auch alle benötigte Symbole in einer einzigen Zeichnung definiert werden. Danach können die Symbole im Modell gelöscht werden, die Die Block-Referenzen (Vorlagen) bleiben erhalten. Die Zeichnung braucht dann nur noch als Vorlage (*.dwt) gespeichert zu und beim Anlegen einer neuen Datei als Vorlage ausgewählt werden.

FAQs

Der Block wird zu groß oder zu klein in die Zeichnung eingefügt

Wenn der Maßstab nicht „passt“, spielt oft der Faktor 1000 (m<>mm) oder 25 (Metrisch<>Zoll) eine Rolle. Achten Sie auf das Einheitensystem der Zeichnung bzw. der Blöcke. Im Modell sollte „Meter“ eingestellt sein unter

Extras > Optionen > Zeichnungseinstellungen > Einheitensystem
. Der Maßstab kann während des Einfügen eines Blocks geändert werden im Block-Einfügen-Fenster oder später in den Eigenschaften des Blocks.

Ich habe einen Block eingefügt aber finde ihn nicht

Zoomen Sie auf die gesamte Zeichnungsausdehnung. Je nach Einfügeoptionen ist er in der Nähe vom Koordinatenursprung gelandet (0,0) oder auf seiner ursprünglichen Position – dazwischen können mehrere Millionen CAD-Einheiten (Meter) liegen, der Block selbst ist nur wenige Meter im Durchmesser => u.U. sind auf dem Bildschirm nur 2 Pixel zu sehen (links unten und rechts oben…). Eventuell wurde der Block in mm eingefügt statt im Meter-Maßstab.

Linien

Der Linienstil (gepunktet, gestrichelt, ausgezogen) ist individuell definierbar. Die Liniendefinition muss in die aktuelle Zeichnung geladen werden, nur dann kann der Stil bequem aus einer Dropdown-Liste ausgewählt und einem beliebigen Linienobjekt oder Layer zugewiesen werden. Die Farbegestaltung ist unabhängig vom Linienstil!

Die Linienstile wird in einer Textdatei beschrieben mit dem Namen meinname.LIN. Diese Datei kann mit jedem gewöhnlichen Editor bearbeitet werden. die Datei muss im „txt“-Format abgespeichert werden, nicht im Word-Format o.ä.

Kontrollieren Sie den Pfad 

Menu>Extras>Optionen>Dateiposition>Zeichnungsunterstützung>Linienart-Datei
 und nehmen Sie die gegebenenfalls dort vorgefundene Datei als Vorlage zur Erstellung eigener Linienstile. Kopieren Sie diese Datei in das oben beschriebene Zentralverzeichnis und ändern Sie den Pfad in den Optionen.

Beispiele:

*DASHDOT,Dashdot __ . __ . __ . __ . __ . __ 
A,0.5,-0.25,0,-0.25

*DASHDOT = Name
Dashdot __ . __ . __ . __ . __ . __ = Beschreibung
A     = Ausrichtung
0.5   = Breite des Strichs (Einheiten = Meter)
-0.25 = Zwischenraum von 0.25 Einheiten Breite
0     = Punkt
-0.25 = Zwischenraum von 0.25 Einheiten Breite

Weitere Beispiele:

*DASHDOT2,Dash dot2 ____ . ____ . ____ . 
A,1.0,-0.25,0,-0.25
*DOTS, Dots . . . . . . . .
A,0,-0.2
*DOTS2, Dots2 .  .  .  .  .  .  .  .
A,0,-0.4
*GASLEITUNG,Gasleitung ----GAS----GAS----GAS----GAS----GAS----GAS--
A,12.7,-5.08,["GAS",STANDARD,S=2.54,U=0.0,X=-2.54,Y=-1.27],-6.35

FAQs

Einzelne Linienstücke zu Polylinien verbinden

Oftmals bestehen scheinbar zusammenhängende Linien aus einzelnen Linienstücken (im Bild obere Linie), statt aus einer Polylinie, die in ihrer gesamten Länge mit einem Mausklick markiert werden kann (im Bild untere Linie).

So wandeln Sie mehrere Linienstücke in eine Polylinie um – achten Sie auf den Text und die vorgeschlagenen Eingaben im Befehlsfenster!

  1. Tastatureingabe: pedit RETURN Mehrfach RETURN
  2. Markieren Sie alle Linienstücke, z.B. einzeln nacheinander und dabei SHIFT-Taste gedrückt halten oder ein Fenster um alle Linienstücke ziehen, dann RETURN
  3. Tastatureingabe: Verbinden RETURN RETURN

Im letzten Schritt von Schritt 3 wird die Frage nach der Lückentoleranz ignoriert, da die Linienstücke idealerweise lückenlos aneinander anstoßen. Schritt 4 verlässt den Befehlsmodus, mit einem Mausklick kann nun die neue Polylinie angeklickt werden.

Alternativer Weg: Das erste Linienstück wird in eine Polylinie umgewandelt, dann die restlichen Linien zugefügt:

  1. Tastatureingabe: pedit RETURN  oder
    Ändern > Element > Polylinie
  2. Erstes Linienstück markieren, RETURN (Linienstück wird in den Typ Polylinie umgewandelt)
  3. Tastatureingabe: Verbinden RETURN
  4. Alle weiteren Linienstücke markieren, RETURN
Polylinien schließen
  1. Auf Polylinie doppelklicken
  2. Tastatureingabe: Schließen