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How to Process RTK Data
How to Process RTK Data 
TopSURV software allows a user to collect and save Real Time 
Kinematic (RTK) data to a job on Topcon Controllers with Windows 
CE and/or Controllers with Windows Mobile OS. TopSURV jobs 
have ‘tsj’extention. ActiveSync® software running on a computer is 
needed to transfer jobs between the controllers and the computer. 
ActiveSync® is a free software from Microsoft® that establishes a 
connection between a computer (with operating system Windows XP) 
and an external device.  If the user's computer operates under 
Windows Vista, ActiveSync is not needed. A connection between the 
computer and an external device with Windows CE/Windows Mobile 
will be automatically established after connecting your device to your 
computer via USB or COM ports.

Working with RTK data in Topcon Tools can be divided into two 
stages:

• creating a job in Topcon Tools and exporting this job to a 
Controller

• importing the job with field data from a controller to a computer, 
viewing and editing data, exporting to any desired file format.

To import/export, view and edit RTK data in Topcon Tools,  only 

RTK module has to be activated:

Creating TopSURV Job in Topcon 
Tools
There are two ways to create a TopSURV job:

• directly in Controller

• using Topcon Tools  
P/N 7010-0928 1



If a user uses Topcon Tools for creating a TopSURV job, he can 
prepare a job to collect field data in TopSURV. This tsj job will 
contain:

•  set of control points,

•  code library,

•  set of layers,

and the following separate files for this job:

•   a georeferenced background image for work area,

•   the desired geoid file for work area.

It is good to use Topcon Tools for selecting the coordinate system, 
preparing the geoid of minimal size, georeferencing the background 
image and importing the necessary set of points. Generally,  for 
preparing a TopSURV job, Topcon Tools is used only once when 
creating the initial  job for a local region.

How to Create a Geoid for Local Area
To save the internal memory of the Topcon Controller, we 
recommend creating the geoid file for the local region.  For this 
procedure the user has to know the coordinates of boundary points of 
the work area and to have the original geoid file which is used for this 
area. As an example,  let us create the geoid for the following area,

using  g2003u07.bin as the base geoid model.

To create the geoid file for local work area, do the following:

1. Run Topcon Link (this is a free Topcon software),
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How to Process RTK Data
2.  Click File -> Convert Files  ,

3.  Click the Add files button in the Convert Files window, select the 
file format ‘USA 99 and 2003 Geoid’, navigate to the location of  
"g2003u07.bin" file, select this file and click the Open button:

4. In the Destination file name field, enter the name of created geoid 
file (for example: MY_GEOID.gff):  

5. Specify positions for the points limiting the use of this geoid 

model:

6. Press the button  to start creating the local geoid
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7. If the file was created successfully, the File Status field will 
display: 

8.  Click OK.

This geoid file is ready for use in TopSURV. Copy the file into the 
Controller with TopSURV.

How to Import Control Points to the Job
It is useful to have in the TopSURV job true coordinates of the base 
station in the given coordinate system, and also coordinates of  the 
control points in a local coordinate system to perform localization 
directly in TopSURV job.

Topcon Tools allows importing a text coordinate file that does not 
contain information about the coordinate system. These files contain 
ONLY the values of coordinates. To import the point coordinates in 
the corresponding coordinate system, the user has to:

•  know this coordinate system or projection,

•  set this coordinate system / projection as current (in the Job 
Configuration window ) before importing.

To import control points to the job, do the following:

1. Run Topcon Tools

2. Create a new Topcon Tools  job: Click Job->New Job and type in 
a job name: 
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How to Process RTK Data
3.  For example, let us create the coordinate file for the base RTK 
station in SPC-83 grid system, zone Ohio (North) using the text 
editor Microsoft Notepad, and then import this file to the Topcon 
Tools job: 

4. Click Job->Job Configuration->Coordinate System, select Ohio 
(North) projection in the Projection field,   

select Grid coordinate system in the Coordinate Type field, 

click  Job->Job Configuration->Units and select US Feet in the field: 

Click OK in the Job Configuration window to save this configuration 
of the Topcon Tools job. The Status Bar will display the selected 

projection and linear unit:

5. To import this file, click  Job->Import, select the file format 
‘Name,N,E,Z,Code’, navigate to the location of the desired text 
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file (‘Base_Coordinates.txt’) and click Open on the Open dialog 
box:

The Points tab displays the coordinates in the desired projection and  

linear units  :

Before importing a text coordinate file with local coordinate points,  
set the Ground coordinate system in the Status Bar 

 and perform the steps which described on 

page 1-5. 
Topcon Tools Processing RTK Data Application Guide6



How to Process RTK Data
After importing the local points, the Map View and the Tab View will 
display these points:

How to See Imported Points on Google Earth
 To see and check where imported points (in Grid coordinate system) 
is located, click View->Google Earth:  

How to Create Background Map for Work Area 
If the user has a digital image in one of the following formats: JPEG 
(*.jpg), Bitmap (*.bmp) or TIFF (*.tif), the user has to georeference 
the image to use it as background. To calculate relationship between 
the image and real coordinate system, the user needs to know 
minimum three of picture points in the desired coordinate system.   
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Let us create the georeferenced image for the JPG file which covers 

the work area:

To georeference the image using Topcon Tools, do the following:

1. The image georeferencing parameters (the coordinate system, the 
coordinate type, and metric unit) are defined by the same 
parameters selected in the Status bar.  Set the coordinate system 
and linear unit which will be used in the TopSURV job: 

2. Click View->Background images and click the Add Image button 
in the Background images dialog box.

3. If the image is not georeferenced, Topcon Tools automatically 
opens the Set Georeference dialog box. This dialog box allows 
the user to mark the photo points on the image:

•  Click Add point in the Toolbar of this window. The cursor 

changes into  (add point cursor).

• Using the ‘add point’ cursor, identify and left-click the desired 
point on the image using a photographic sketch of ground point. 
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How to Process RTK Data
Type in the point name in the Label field,  the point coordinates 
in the current coordinate system and click OK to mark this point:

• Using this technique, mark other photo points.

• Click  button to georeference the image. After 

transforming, the Set Georeference dialog box will display the 
image in the current coordinate system:
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• To save the transformed image, click the Finish button in the Set 
Georeference dialog box. Navigate to the location in which to 
save the file and type in the file name in the corresponding field 
of the Save dialog box. Click Save to complete:

 Topcon Tools creates and saves two file types in the selected folder:

• The transformed image in the same format which was selected for 
the image that was not georeferenced

• ESRI World File Format 

These both files are ready to be used in TopSURV. Copy the files into 
the Controller with TopSURV installed.

How to Create a User’s Layer

To create a new layer in the current job, click Add->Layers 
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How to Process RTK Data
1.  On the General tab of the Layer dialog box, enter the following 
general parameters for the layer: 

• Name – the name of the layer.

• Note – enter desired comments.

• Breakline Type- select Auto.

2. On the Plotting Styles tab, select the following parameters for the 

layer: 

• Line Style – select the type of line to display line information in 
the layer.

• Line Width – select a width for lines in the layer.

•  Color – select a color for all data (point and line) in the layer.

•  Point Symbol – select a symbol to represent all points in the

layer.

3. On the Area tab, check the Fill Area field to fill the areas in this 
layer: 
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Topcon Tools allows you to create and save unlimited number of the 
different layers in the current job. 

To view all job’s layers, click View->Layers:

This tab also allows one to edit the layer’s parameters.

How to Create User’s Codes

To create a new code in the current job, click Add->Code 

1. On the General tab, edit the code’s name and select the desired 
type (Point, Line, Area, Auto) and the layer

2. On the Plotting styles tab, select the line color, line style and line 
width. The line’s plotting style can be edited for any code with or 
without a layer:
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How to Process RTK Data
3. On the Point tab, select the point color, point symbol. The points 
plotting style can be edited for any code with or without a layer

4. On the Area tab, select the area color. Check the Fill Area field, to 
fill the areas of this code.

Topcon Tools allows you to create and save unlimited number of the 
different codes in the current job. 

To view all job’s layers, click View->Codes.This tab also allows one 
to edit the code’s parameters and to add desired attributes for the 
corresponding code.
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How to Export a Topcon Tools Job to TopSURV 
Job
To export the current Topcon Tools job to a Topsurv job, click Job-> 
Export, select the file format ‘TopSURV 7 Job’ and type in the name 
of the TopSURV job. 

Click OK to start creating the TopSURV job. 

How to Export a TopSURV Job to Controller
We have created the TopSURV job from the Topcon Tools job, 
which contains the control points in the different coordinate systems 
and the set of layers and codes. Also we created the local geoid and 
the georeferenced image for the work area. All these files were saved 
in the same folder on the computer. 

If you have Windows XP operation system, make sure that Microsoft 
ActiveSync is installed on the computer and a successful computer-to-
device connection is established. In this case the system tray displays 

a green ActiveSync circle .

To export the created files into the Controller, close the Topcon Tools 
job and open Windows Explorer.  Click the Mobile Device folder. 
The right-hand panel of the window displays the contents of the 
Topcon

Controller:
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How to Process RTK Data
 To export the tsj job, open the folder \TPS\TopSURV\ \Jobs on the 
Controller and copy this job to the selected folder:

To export the created geoid file, open the folder \TPS\ TopSURV\ 
Geoids on the Controller and copy this file to the selected folder:

To export the created georeferenced image, open the folder \ 
\TPS\TopSURV on the Controller and copy these file to the selected 
folder.

Importing, Viewing and Editing 
TopSURV Job in Topcon Tools
This chapter describes how the user can use the Topcon Tools 
software for importing, viewing, editing a TopSURV job, and 
creating reports for this TopSURV job.

How to Import a TopSURV Job to Computer
After collecting field data and performing localization using control 
points, the closed TopSURV job is ready for import to Topcon Tools 
for viewing and editing.
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Run Topcon Tools and create a new job. Click Job-> Import from 
Device, select mobile device and navigate to the location of  "from 
topcon tools.tsj" file (Storage Card/TPS/TopSURV/Jobs).  

Click Open in this dialog box to start import the TopSURV job to the 
current Topcon Tools job.

The created Topcon Tools job and the imported TopSURV job have 
different configurations. In process of import of the TopSURV job, 
Topcon Tools offeres to set the desired configuration in the Override 
Job Configuration dialog box. In this case we recommend setting the 
configuration used in the TopSURV job: 

If the geoid used in TopSURV is not presented in the current Topcon 
Tools job, the following message will appear:
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How to Process RTK Data
To continue import of the TopSURV job to the Topcon Tools job, 
click OK. 

How to Add a Geoid File to Topcon Tools Job
For correct calculation of points elevations, add the geoid to the 
current job:

1.  Click Job->Job Configuration->Coordinate System and click the 
Geoid List button 

2. Click the Add button on the Geoid List dialog box, select the file 
format ‘Topcon Geoid’,  navigate to the location of the local 
geoid (‘MY_GEOID.jff’) and click Open on the Open dialog box:
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3. The Geoid List dialog box displays the area covered by the geoid: 

To add this local geoid to the current Topcon Tools job, click the 
Close button on the Geoid List dialog box and select this geoid from 
the  Geoid list on the Job Configuration window: 

After setting the desired geod, Topcon Tools automatically 
recalculate the orthometric heights of the imported job.

Note, that orthometric heights will be displayed if either  Ground,

Grid, or Datum Elevation is selected in the Status Bar.  In this case, 
the orthometric heights are displayed in the ‘Elevation’ column of the 
Points tab.

Viewing Collected Data 
After importing the TopSURV job to the Topcon Tools job, all 
collected data can be displayed in the Tab View, Map View, Cad View 
and Google Earth View:

 The Points tab displays the coordinates of the points measured 
from the base station in the selected coordinate system,  standard 
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How to Process RTK Data
deviations for each component of RTK observations, codes and 
layers in use:

 The GPS Occupations tab displays information about collected 
occupations (used antenna type, antenna height, duration, method 
of measurements, recording interval):

The GPS Observations tab displays the name of point “from” and 
point “to”, horizontal/vertical precision of the vector, components 
of computed vector, and information about solution type.

 The Map View is a graphical view of latitude/longitude or 
northing/easting of points, observations and background map
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The CAD View is a graphical view of linework, roads, and 
surfaces with the associated points:

The Google Earth is a client application to work with a 3D map 
of the Earth created using live satellite imagery (a connection 
with the Internet is needed):

How to Estimate Precision of Data
To estimate the precision of each GPS observation of the job, it is 
useful to automatically mark those vectors, which have the precision 
worse than the values set in this job by the user. The user can set 

            MAP View                                CAD View
Topcon Tools Processing RTK Data Application Guide20



How to Process RTK Data
threshold values in the GPS Obs Precisions tab (Job Configuration -> 
Quality Control) and activate this test in the Automatic Tests tab: 

After that Topcon Tools will automatically highlight in red the ‘bad’ 
GPS observation(s):

Viewing and Editing Localization 
If localization was performed in TopSURV, the user can see (in the 
current Topcon Tools job) the localization parameters and pair points 

a)

b)

in the GPS Observations tab                                                 in Map View
P/N 7010-0928 21



which were used in localization. To open the Localization dialog box, 
click Process->Localization:

The Localization window allows one to add the pair points for 
calculating the localization parameters:

• before adding a new pair, be sure that the Points tab contains the 
desired point(s) with coordinates in the both coordinate systems 
(Ground/Localization and Grid/Datum). If needed, to create such 

a point, you can use the option Add -> Point ( ) 

and type in the desired coordinates in the corresponding 

coordinate system:

• Click Add Point in the Localization window.

• Select the desired point from the WGS Point list:  
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How to Process RTK Data
• Select the desired point from the Local Point list:

• Click  to calculate localization parameters using new 

pair points.

Editing Antenna Height
Topcon Tools allows one to edit the Antenna Height and/or Antenna 
Height Method and/or Antenna Type columns as needed. For multiple 
points:

•  in the GPS Occupations tab press Shift (and/or Ctrl) and 
highlight the desired 

points:

•  click a point:

• type in a new height:  
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• press Enter:

After this updating, you need to recalculate the coordinates of the 
network. 

How to Recalculate the Coordinates
To recalculate the coordinates of the given RTK network with any 
modification, click the Process -> Compute coordinates.

Note that if the base station antenna does not have information about 

antenna type, antenna height and antenna height method, the phase 
center coordinates of this antenna will be used to compute the 
coordinates of all points in this network.

Reporting Data 
To create a report in Microsoft Excel for all GPS observations of the 
given job, take the following steps:

• Click Report-> Report Configuration 
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How to Process RTK Data
• Select the GPS observations  report in the Report list and 
Microsoft Excel in the Report format field: 

• Click OK to save that report configuration.

• To create the corresponding report, click Report-> GPS 
Observations. The following report displays
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Export to Coordinate File
To export the coordinates of the measured RTK points to a text file 
format, do the following:

• Select the desired linear unit (US Feet) and coordinate system 

(Ground/Localization) in the Status Bar  

• Click Job-> Export, select the file format ‘Name,N,E,Z,Code’, 
type in the name of the created file and click OK: 

 The created file will have the following type:
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